Unable to test, Error says can't locate Package.StoreAssociation.xml

Dec 19, 2012 at 10:10 PM

Good Evening All,

I'm very new to coding so I could be making a very simple error but everytime to try to run the app I receive the following error:
Error 4 File 'Package.StoreAssociation.xml' not found. C:\Users\Adam\Desktop\MetroPress\package.appxmanifest 1 1 MetroPress

I've tried running as Local Machine, Simulator and Debug but always the same message. I've double checked the Quick Start Guide and can't see I;ve missed any issues.

The file is there as I can Open within Visual Basic so unsure why the project cannot find when building the app.

Many thanks in advance for any help.
Adam

Developer
Dec 27, 2012 at 10:42 PM

Are you using Microsoft Visual Studio Professional to run the project? Try re-download the source and see if you can run it. You should be able to run it without any error right after you download it.

 

Jan 8, 2013 at 7:29 PM

I'm using Visual Studio Express, but I've re-downloaded the latest source code and works fine now. :) Thank you.

Only issue I now have is with changing the appTitleImage, whenever I add a URL in their is fails to build. Do you need to enter it with any special characters?

 

Many Thanks,
Adam

Jan 9, 2013 at 4:17 AM

Hi Adam,

1. Did you enter the full url with http://? 

2. Did you increase the localStorageSchemaVersion number in Line 6 under wpapi.js?

What error message did you get?

Cheers,

Michael

Jan 13, 2013 at 9:49 AM

Hi Michael,

1. Yes enter the full URL, like so
 appTitleImage: http://www.16bits.co.uk/wp-content/uploads/2010/09/16bitslogoBanner2.png

First Error I receive is:
JavaScript critical error at line 24, column 28 in ms-appx://metropress/js/wpapi.js SCRIPT1009: Expected '}'
And is also errors with this afterwards:
"Exception is about to be caught by JavaScript library code at line 13, column 13 in ms-appx://metropress/js/default.js
0x800a1391 - JavaScript runtime error: 'WPApi' is undefined
If there is a handler for this exception, the program may be safely continued."
 
Thanks for your help Michael.
Jan 13, 2013 at 4:08 PM

Hi Adam,

You are having a javascript error and I believe that you didn't end your statement correctly.

your line should read.

appTitleImage: "http://www.16bits.co.uk/wp-content/uploads/2010/09/16bitslogoBanner2.png",

Note that you need the double quote ", and the comma a the end of the line.

If that still doesn't work, please post part of your code here. Let me know.

 

Michael Siu